exercice sur les tableaux II

Aller en bas

exercice sur les tableaux II

Message par anisagrebi le 20th Novembre 2008, 23:12

Écrire un programme en pascal permettant de

  • remplir un tableau de 10 dates sous la forme JJ-MM-AAAA
  • d'afficher les dates dont l'année est bissextile sous la forme l'élément N°[i] est une année bissextile.

anisagrebi

Nombre de messages : 9
Date d'inscription : 12/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

réponse

Message par anisagrebi le 20th Novembre 2008, 23:23

pour i de 1 à 10 faire
ecrire ("donner l'element N° [ ",i," ] :");
lire (t[i])
finpour
pour i de 1 à 10 faire
AAAA <-- sous-chaine (t[i],7,4)
valeur (AAAA, annee,Err)
si (annee mod 4 = 0) alors
ecrire ("l'element N° [ ",i," ] est une année bissextile")
finsi
finpour

anisagrebi

Nombre de messages : 9
Date d'inscription : 12/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

traduction pascal

Message par anisagrebi le 20th Novembre 2008, 23:27

anisagrebi a écrit:pour i de 1 à 10 faire
ecrire ("donner l'element N° [ ",i," ] :");
lire (t)
finpour
pour i de 1 à 10 faire
AAAA <-- sous-chaine (t[i],7,4)
valeur (AAAA, annee,Err)
si (annee mod 4 = 0) alors
ecrire ("l'element N° [ ",i," ] est une année bissextile")
finsi
finpour

[i]traduisez ce pseudo code en Pascal

anisagrebi

Nombre de messages : 9
Date d'inscription : 12/02/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: exercice sur les tableaux II

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum